JND Networks LLC

Cisco Router with a single connectivity.

Configs

!
hostname Customer
!
ip domain name jndnetworks.com
ip name-server 8.8.8.8
!
username Aldwin privilege 15 secret 5 $1$pQHB$1gMQLn8b/piDPEpMg9SPT/
!
!
ip tcp synwait-time 5
ip ssh version 2
!
interface GigabitEthernet0/0
description WAN
ip address 10.0.0.2 255.255.255.0
ip nat outside
media-type gbic
speed 1000
duplex full
negotiation auto
!
interface GigabitEthernet1/0
description LAN
ip address 172.16.123.1 255.255.255.0
ip nat inside
negotiation auto
!
ip nat inside source list LAN_NAT interface GigabitEthernet0/0 overload
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
ip access-list standard LAN_NAT
permit 172.16.123.0 0.0.0.255
!
line vty 0 4
login local
transport preferred ssh
!
!
end

Steps:

1. Configure WAN IP
2. Create Username and Password
3. Configure and enable ssh
4. configure public DNS
5. Configure default static route
6. configure and test NAT
1. Configure the proper interface for instance in my case the IP is static if your IP is dynamic just type "ip address dhcp" instead of putting the IP manually, and do a ping test.
1.1Ping is successful
2. First I created a username "Aldwin" with password/secret "P@ssword" with a privilege of 15 which allow me to read and modify the router
2. Now Lets enable configure and enable ssh
2.1 Create IP domain-name
2.2 Generate Keys

When Prompt please put "2048" to generate keys in 2048 bit
2.3 Enable ssh version 2 and implement it on line vty
2.4 Test ssh locally and make sure you exit after verifying
3. Default Static Route
3.1 test by pinging google public dns (8.8.8.8)
3.2 Lets try to ping it so DNS can resolve it
3.3 Looks like it won't work lets fix it by typing the following commands
Now all is good
4. Configuring NAT
4.1 identify your NAT ports; As you can see the WAN port needs to be as NAT outside and LAN as inside NAT
4.2 create a ACL for LAN which you want to translate
4.3 Configure NAT and run a Debug for testing
4.4 Test from end-user

Knowledge

Cisco IOS
IOS base config
IOS VS IOS XE
OSPF
EIGRP
BGP
Layer 2